Page 1 of 1

Earthmate LT-40 GPS Problem

Posted: Wed Sep 03, 2008 7:16 pm
by SanFranDiver
About 6-10 seconds after I click the "USE GPS" button I get an brief flashing error message that begins

ERROR - Buffer empty for more than.....


and none of the found networks ever get Lat Lon data.

I have the GPS correctly set for Com 1 9600bps which works flawlessly with my Delorme Streets Atlas 2009.

Help/suggestions

Thanx

Re: Earthmate LT-40 GPS Problem

Posted: Wed Sep 03, 2008 9:44 pm
by ACalcutt
Hmm... For some reason when vistumber is trying to get the gps data off the gps it is not finding any. If it finds nothing for 10 seconds i use it as an indication that the gps in no longer attached and it turns the gps off.

Have you tried CommMG instead of Netcomm (in the gps settings). Does that work?

Also, I have never tried a 9600baud gps (all the ones i have use are 4800). So i am wonding if anyone else has used 9600 (it should work...but its untested)

Re: Earthmate LT-40 GPS Problem

Posted: Sun Oct 19, 2008 6:41 am
by irv
Just making sure, but you've set up the serial emulation driver?

If not, head on over to http://www.delorme.com/support/supportt ... spx?id=319 and map the COM port.

Re: Earthmate LT-40 GPS Problem

Posted: Mon Jun 08, 2009 1:12 pm
by ACalcutt
For the user who posted here before I had to revert the site to my last backup, did you ever make any more progress?

When using the gps with xport do you see data (like GPGGA text) at the bottom of the xport window?

Re: Earthmate LT-40 GPS Problem

Posted: Tue Jun 16, 2009 7:15 pm
by AltF4
I was wondering what happened! My posts and account just sort of disappeared. I started to question whether I had posted here at all, or just dreamed it! :)

Anyway, I gave up. :( I wasn't able to get the GPS working, and if I waited any longer the return period would have run out. The LT-40 wouldn't even interface with Google Earth, much less Vistumbler. So I don't think it was your (Vistumbler's) fault.

So now I'm in the market for a new GPS! Fry's Electronics only had one other model, though. It was a Microsoft "Streets and Trips" software box that includes a USB GPS device with it. I read every inch of the box, (and the respective website, http://www.microsoft.com/STREETS/en-us/ ... 09GPS.aspx) but there's no information on what that GPS device actually is. When shopping for this sort of thing, I prefer to go to a brick-and-mortar store. Entirely so that inevitable returns are easier.

Re: Earthmate LT-40 GPS Problem

Posted: Wed Jun 17, 2009 8:20 am
by ACalcutt
I use a microsoft GPS myself. I have both the old GPS-360 and the newer GPS-500 and they both work great. I'm not sure what they are selling now, but i'm sure it will work like the others did.

(btw...sorry about the inconvenience with your accounts and post. I was trying to resolve an issue streaming video from my esx server (which i finally fixed by upgrading to ESX4i) and I accidently corrupted my VM raid array. So, luckily I actually had a week old backup and didn't lose much)

Re: Earthmate LT-40 GPS Problem

Posted: Thu Jul 16, 2009 3:44 pm
by WinstonP
I know that Netstumbler doesn't work with Vista but it DOES see the LT-40 when set up with the DeLorme Serial Emulator, so I'm thinking it's a Vistumbler problem not picking up the LT-40 data.

Re: Earthmate LT-40 GPS Problem

Posted: Thu Jul 16, 2009 5:37 pm
by ACalcutt
Unfortunately I have no way to try and figure this out without having a gps to test with. Anyone want to sell, donate, or let me borrow one? The lowest cost I have seen is $49, but I don't really need another gps.

Re: Earthmate LT-40 GPS Problem

Posted: Mon Jul 20, 2009 1:40 am
by mysticvirgo67
Well, Anfrew, I could always use another GPSr. lol.. By one and I wil give you a fair price when you are done LOL ;) Failing that , there is always Ebay :))

Re: Earthmate LT-40 GPS Problem

Posted: Mon Jul 20, 2009 9:31 am
by ACalcutt
Are you using a LT-40 now mystic? Are you able to get it to work with vistumbler?

Re: Earthmate LT-40 GPS Problem

Posted: Mon Jul 20, 2009 7:54 pm
by mysticvirgo67
NOw I am runnin on a Microsopft/Pharos 500. works a charm except for a good deal of position 'wandering' in a typical GPS 30ft circle of error. Mostly becasue it is velcroed to the lid of my lap-a-ma-top and THAT gets moved around a good deal inside the van.

IF I can the second phase of warscout to gel, I hope to have it mounted alongside the radio on the mast.

Re: Earthmate LT-40 GPS Problem

Posted: Thu Oct 29, 2009 9:26 am
by romeomoon
I am in the same boat. Street Atlas USA with the LT-40.

It works great with NetStumbler in XP, but I have beat my brains out trying to get it to work with Vistumbler and it still DOES NOT WORK.

So vistumbler is just for static operations and I have to carry a second laptop for wardriving.

It sure would be nice if someone got this to work and gave a detailed step by step process to get it to work with Vistumbler.

Also how does one get the Google Earth to come up as displayed on the home page? Thats another mystery.

Re: Earthmate LT-40 GPS Problem

Posted: Thu Oct 29, 2009 2:03 pm
by pferland
Like Andrew said in a previous post, we need to acquire an LT-40 in order to get it working with Vistumbler.

To get google Earth to look like it does in the screen shot all you have to do is manually shape the windows to look like that, there was nothing special to it.

To have Earth open with the network link go to: Extra->Open KML NetworkLink
To have the Compass open go to: Extra->GPS Compass
To open the GPD details window go to: Extra->GPS Details

Then just re-arrange the windows as you see fit.

Re: Earthmate LT-40 GPS Problem

Posted: Thu Oct 29, 2009 11:58 pm
by mysticvirgo67
Sorry, haven't found an LT-40 yet... Will keep an eye out

I have noticed that my current GPSr gives the same error as the OP, learned that it has to do ith the length of time it takes a given model GPS to 'warm up' or acquire at a cold start. My current unit has a 6 second coldstart. First start up always gives me that error, but if I repeatedly click the usde gps button, it does catch on 3rd or 4th try. I also think it is possible that the OP may not have been using the correct USB/COM number??

Re: Earthmate LT-40 GPS Problem

Posted: Fri Oct 30, 2009 10:12 am
by pferland
I need a new GPS, so I was just going to cave in and get one.
Hopefully Andrew can get it working quickly so I can wardrive
/me waves fist :twisted:

Re: Earthmate LT-40 GPS Problem

Posted: Fri Oct 30, 2009 12:28 pm
by mysticvirgo67
Which GPS (s) do you currently have in your inventory?
I hope you also get to play with mysticache a bit. More and more alpha testing

Have you looked into Geocaching? Ties nicely into wardriving... Similar in a way. Cant get anymore geek than using multi billion dollar technology to find tupperware in the woods... or a one milliliter container in a brick wall.

LOL

Ummm who is the nufacturer of the LT-40?

Re: Earthmate LT-40 GPS Problem

Posted: Fri Oct 30, 2009 12:46 pm
by pferland
I've just been commandeering Andrews GPS's until I can get a new one since my last one was stolen :-(

I have no idea who makes it, I just decided to get it when me and Andrew were talking last night about more people having it and it not working with Vistumbler.
We also joked about making a "Community Donations for Hardware Development Fund."

Re: Earthmate LT-40 GPS Problem

Posted: Fri Oct 30, 2009 1:06 pm
by mysticvirgo67
Can always go beggarware with Vistumbler... No wait.. that would require registering as an actual business...

Re: Earthmate LT-40 GPS Problem

Posted: Fri Oct 30, 2009 1:08 pm
by mysticvirgo67
well, at least you didn't end up sending your childern door to door to sell candybars LOL no wait that wasnt LOL, that was :((

Re: Earthmate LT-40 GPS Problem

Posted: Tue Nov 23, 2010 7:42 pm
by beads
Okay, now.

Lets start off why Vistumbler doesn't work in Vista/Win7. The fine people at DeLorme no longer support the serial driver development. Complaining that its "too difficult" to write a virtual serial driver. Unlike Verizon, RIM, Google (Andriod), Samsung and every other smart phone manufacturer out their on the planet. Most of these various driver support was dropped back in May 2010 as the whole 'Street View' fiasco popped up in Germany and the US. Anyhow. They don't want to port over to the Vista/Win7 platform.

The DeLorme LT-40 works just fine with the serial driver on XP and basically XP only. Can't confirm or deny the PN series until I can make it 'clearly' out of the Chicago canyons I face right now. Will try over the long holiday weekend on the PN-40.

Optimally, I'd love to get this to work cleanly on a Win7 box without loosing teeth myself. Really, I've tried a variety of different software "shims" to no avail. But nothing works well or at all on the Win7 netbook.

- beads

Re: Earthmate LT-40 GPS Problem

Posted: Thu Nov 25, 2010 2:47 am
by pferland
I just ended up abandoning the LT-40, cant remember if it was because of no support for Vista/Win7 at all or that it was 32bit only, but I needed a 64bit compatable GPS, so I just got another Microsoft GPS.

Earthmate LT-40 GPS Problem

Posted: Tue May 03, 2016 9:25 am
by arizonajon
If you got it to work, that's great! Good way to put an old GPS to work.

Did you do any Vistumbler runs and upload them to the database?

Cheers - Jon N7UV

Earthmate LT-40 GPS Problem

Posted: Tue May 03, 2016 4:28 pm
by ACalcutt
If you have to repeatedly click use gps to get it to work, you may want to uncheck the option (Settings --> GPS Settings --> Disconnect GPS when no data is recieved in over 10 seconds). Sometimes if your gps takes a while to get a fix this will disconnect you because it thinks your aren't receiving any gps data.

Re: Earthmate LT-40 GPS Problem

Posted: Mon May 13, 2019 1:38 pm
by user20190513
irv wrote:
Sun Oct 19, 2008 6:41 am
Just making sure, but you've set up the serial emulation driver?

If not, head on over to http://www.delorme.com/support/supportt ... spx?id=319 and map the COM port.
Does anyone have these drivers? Garmin removed everything delorme-related :evil: I could really use them right now

Re: Earthmate LT-40 GPS Problem

Posted: Wed May 15, 2019 8:40 am
by user20190513
I spent hours searching archive.org for an old copy of Delorme's website. I found them and wanted to share them if anyone is interested. Got it to work with my delorme earthmate usb puck and windows xp 32bit

justinolanin.com/downloads/DeLorme Serial Emulator1.1.exe

justinolanin.com/downloads/USBEMate2.exe

I had to install both to get it to work for some reasons. If anyone needs more stuff from Delome's website, its on archive.org. Garmin erased just about every other trace of Delmore on the net.

Re: Earthmate LT-40 GPS Problem

Posted: Wed May 15, 2019 9:35 pm
by ACalcutt
glad to see you found it. I looked around a bit but I had no luck. It's kind of sad garmin removed all the delorme stuff... i had not idea they even bought them.